What’s Vulnerable › Vulnerabilities
CVE-2024-42140: riscv: kexec: Avoid deadlock in kexec crash path
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-30 · updated 2026-06-17
- Weakness: CWE-667
Description
In the Linux kernel, the following vulnerability has been resolved: riscv: kexec: Avoid deadlock in kexec crash path If the kexec crash code is called in the interrupt context, the machine_kexec_mask_interrupts() function will trigger a deadlock while trying to acquire the irqdesc spinlock and then deactivate irqchip in irq_set_irqchip_state() function. Unlike arm64, riscv only requires irq_eoi handler to complete EOI and keeping irq_set_irqchip_state() will only leave this possible deadlock without any use. So we simply remove it.
Affected products
- Linux kernel: from 5.15.82 before 5.15.163; from 6.0.12 before 6.1.98; from 6.2 before 6.6.39; from 6.7 before 6.9.9 — fixed in 5.15.163, 6.1.98, 6.6.39, 6.9.9
How to fix
Upgrade to a fixed version: Linux kernel 5.15.163, 6.1.98, 6.6.39, 6.9.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/484dd545271d02d1571e1c6b62ea7df9dbe5e692
- https://git.kernel.org/stable/c/653deee48a4682ea17a05b96fb6842795ab5943c
- https://git.kernel.org/stable/c/7692c9b6baacdee378435f58f19baf0eb69e4155
- https://git.kernel.org/stable/c/bb80a7911218bbab2a69b5db7d2545643ab0073d
- https://git.kernel.org/stable/c/c562ba719df570c986caf0941fea2449150bcbc4
- https://git.kernel.org/stable/c/484dd545271d02d1571e1c6b62ea7df9dbe5e692
- https://git.kernel.org/stable/c/653deee48a4682ea17a05b96fb6842795ab5943c
- https://git.kernel.org/stable/c/7692c9b6baacdee378435f58f19baf0eb69e4155
- https://git.kernel.org/stable/c/bb80a7911218bbab2a69b5db7d2545643ab0073d
- https://git.kernel.org/stable/c/c562ba719df570c986caf0941fea2449150bcbc4
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-42140 or the next vulnerability affects your stack