What’s Vulnerable › Vulnerabilities
CVE-2024-42150: net: txgbe: remove separate irq request for MSI and INTx
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-30 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: net: txgbe: remove separate irq request for MSI and INTx When using MSI or INTx interrupts, request_irq() for pdev->irq will conflict with request_threaded_irq() for txgbe->misc.irq, to cause system crash. So remove txgbe_request_irq() for MSI/INTx case, and rename txgbe_request_msix_irqs() since it only request for queue irqs. Add wx->misc_irq_domain to determine whether the driver creates an IRQ domain and threaded request the IRQs.
Affected products
- Linux kernel: from 6.8.12 before 6.9; from 6.9 before 6.9.9; 6.10-rc1, 6.10-rc2, 6.10-rc3, 6.10-rc4, 6.10-rc5, 6.10-rc6 — fixed in 6.9, 6.9.9
How to fix
Upgrade to a fixed version: Linux kernel 6.9, 6.9.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/850103ebe6b062ee0ab0f6670205f861acc76ace
- https://git.kernel.org/stable/c/bd07a98178462e7a02ed2bf7dec90a00944c1da5
- https://git.kernel.org/stable/c/850103ebe6b062ee0ab0f6670205f861acc76ace
- https://git.kernel.org/stable/c/bd07a98178462e7a02ed2bf7dec90a00944c1da5
Get alerted when CVE-2024-42150 or the next vulnerability affects your stack