What’s Vulnerable › Vulnerabilities
CVE-2024-4216: XSS vulnerability in /settings/store API response json payload in pgAdmin 4
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-79
Description
pgAdmin <= 8.5 is affected by XSS vulnerability in /settings/store API response json payload. This vulnerability allows attackers to execute malicious script at the client end.
Affected products
- Fedoraproject Fedora: 40
- pgadmin.org pgAdmin 4: before 8.6 — fixed in 8.6
How to fix
Upgrade to a fixed version: pgadmin.org pgAdmin 4 8.6. Check the vendor advisory for mitigations.
References
- https://github.com/pgadmin-org/pgadmin4/issues/7282
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/T2YFVCB4HCXU3FQBZ5XTWJZWSZUDNCXE/
- https://github.com/pgadmin-org/pgadmin4/issues/7282
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/T2YFVCB4HCXU3FQBZ5XTWJZWSZUDNCXE/
Get alerted when CVE-2024-4216 or the next vulnerability affects your stack