What’s Vulnerable › Vulnerabilities
CVE-2024-4219: SSRF In BeyondInsight
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-04 · updated 2026-06-17
- Weakness: CWE-918
Description
Prior to 23.2, it is possible to perform arbitrary Server-Side requests via HTTP-based connectors within BeyondInsight, resulting in a server-side request forgery vulnerability.
Affected products
- BeyondTrust BeyondInsight: before 23.2 — fixed in 23.2
How to fix
Upgrade to a fixed version: BeyondTrust BeyondInsight 23.2. Check the vendor advisory for mitigations.
References
- https://www.beyondtrust.com/trust-center/security-advisories/BT24-05
- https://www.beyondtrust.com/trust-center/security-advisories/BT24-05
Get alerted when CVE-2024-4219 or the next vulnerability affects your stack