What’s Vulnerable › Vulnerabilities
CVE-2024-42219
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-06 · updated 2026-06-17
- Weakness: CWE-1289
Description
1Password 8 before 8.10.36 for macOS allows local attackers to exfiltrate vault items because XPC inter-process communication validation is insufficient.
Affected products
- 1Password: from 8.0 before 8.10.36 — fixed in 8.10.36
How to fix
Upgrade to a fixed version: 1Password 8.10.36. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-42219 or the next vulnerability affects your stack