What’s Vulnerable › Vulnerabilities
CVE-2024-4223: Tutor LMS <= 2.7.0 - Missing Authorization
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-862
Description
The Tutor LMS plugin for WordPress is vulnerable to unauthorized access of data, modification of data, loss of data due to a missing capability check on multiple functions in all versions up to, and including, 2.7.0. This makes it possible for unauthenticated attackers to add, modify, or delete data.
Affected products
- themeum Tutor LMS – eLearning and online course solution: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 2.7.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3086489/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ce4c4395-6d1a-4d5f-885f-383e5c44c0f8?source=cve
- https://plugins.trac.wordpress.org/changeset/3086489/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ce4c4395-6d1a-4d5f-885f-383e5c44c0f8?source=cve
Get alerted when CVE-2024-4223 or the next vulnerability affects your stack