What’s Vulnerable › Vulnerabilities
CVE-2024-42230: powerpc/pseries: Fix scv instruction crash with kexec
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-30 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: powerpc/pseries: Fix scv instruction crash with kexec kexec on pseries disables AIL (reloc_on_exc), required for scv instruction support, before other CPUs have been shut down. This means they can execute scv instructions after AIL is disabled, which causes an interrupt at an unexpected entry location that crashes the kernel. Change the kexec sequence to disable AIL after other CPUs have been brought down. As a refresher, the real-mode scv interrupt vector is 0x17000, and the fixed-location head code probably couldn't easily deal with implementing such high addresses so it was just decided not to support that interrupt at all.
Affected products
- Linux kernel: from 5.9 before 6.1.98; from 6.2 through 6.6.39; from 6.7 before 6.9.9; 6.10-rc1, 6.10-rc2, 6.10-rc3, 6.10-rc4, 6.10-rc5, 6.10-rc6 — fixed in 6.1.98, 6.9.9
How to fix
Upgrade to a fixed version: Linux kernel 6.1.98, 6.9.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/21a741eb75f80397e5f7d3739e24d7d75e619011
- https://git.kernel.org/stable/c/8c6506616386ce37e59b2745fc481c6713fae4f3
- https://git.kernel.org/stable/c/c550679d604798d9fed8a5b2bb5693448a25407c
- https://git.kernel.org/stable/c/d10e3c39001e9194b9a1bfd6979bd3fa19dccdc5
- https://git.kernel.org/stable/c/21a741eb75f80397e5f7d3739e24d7d75e619011
- https://git.kernel.org/stable/c/8c6506616386ce37e59b2745fc481c6713fae4f3
- https://git.kernel.org/stable/c/c550679d604798d9fed8a5b2bb5693448a25407c
- https://git.kernel.org/stable/c/d10e3c39001e9194b9a1bfd6979bd3fa19dccdc5
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-42230 or the next vulnerability affects your stack