What’s Vulnerable › Vulnerabilities
CVE-2024-42237: firmware: cs_dsp: Validate payload length before processing block
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-07 · updated 2026-06-17
- Weakness: CWE-834
Description
In the Linux kernel, the following vulnerability has been resolved: firmware: cs_dsp: Validate payload length before processing block Move the payload length check in cs_dsp_load() and cs_dsp_coeff_load() to be done before the block is processed. The check that the length of a block payload does not exceed the number of remaining bytes in the firwmware file buffer was being done near the end of the loop iteration. However, some code before that check used the length field without validating it.
Affected products
- Linux kernel: before 5.16; from 5.17 before 6.1.100; from 6.2 before 6.6.41; from 6.7 before 6.9.10 — fixed in 5.16, 6.1.100, 6.6.41, 6.9.10
How to fix
Upgrade to a fixed version: Linux kernel 5.16, 6.1.100, 6.6.41, 6.9.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/259955eca9b7acf1299b1ac077d8cfbe12df35d8
- https://git.kernel.org/stable/c/3a9cd924aec1288d675df721f244da4dd7e16cff
- https://git.kernel.org/stable/c/6598afa9320b6ab13041616950ca5f8f938c0cf1
- https://git.kernel.org/stable/c/71d9e313d8f7e18c543a9c80506fe6b1eb1fe0c8
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-42237 or the next vulnerability affects your stack