What’s Vulnerable › Vulnerabilities
CVE-2024-42238: firmware: cs_dsp: Return error if block header overflows file
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-07 · updated 2026-06-17
- Weakness: CWE-120
Description
In the Linux kernel, the following vulnerability has been resolved: firmware: cs_dsp: Return error if block header overflows file Return an error from cs_dsp_power_up() if a block header is longer than the amount of data left in the file. The previous code in cs_dsp_load() and cs_dsp_load_coeff() would loop while there was enough data left in the file for a valid region. This protected against overrunning the end of the file data, but it didn't abort the file processing with an error.
Affected products
- Linux kernel: from 5.16 before 6.1.100; from 6.2 before 6.6.41; from 6.7 before 6.9.10 — fixed in 6.1.100, 6.6.41, 6.9.10
How to fix
Upgrade to a fixed version: Linux kernel 6.1.100, 6.6.41, 6.9.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/6eabd23383805725eff416c203688b7a390d4153
- https://git.kernel.org/stable/c/90ab191b7d181057d71234e8632e06b5844ac38e
- https://git.kernel.org/stable/c/959fe01e85b7241e3ec305d657febbe82da16a02
- https://git.kernel.org/stable/c/b8be70566b33abbd0180105070b4c67cfef8c44f
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-42238 or the next vulnerability affects your stack