What’s Vulnerable › Vulnerabilities
CVE-2024-42249: spi: don't unoptimize message in spi_async()
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-07 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: spi: don't unoptimize message in spi_async() Calling spi_maybe_unoptimize_message() in spi_async() is wrong because the message is likely to be in the queue and not transferred yet. This can corrupt the message while it is being used by the controller driver. spi_maybe_unoptimize_message() is already called in the correct place in spi_finalize_current_message() to balance the call to spi_maybe_optimize_message() in spi_async().
Affected products
- Linux kernel: from 6.9 before 6.9.10 — fixed in 6.9.10
How to fix
Upgrade to a fixed version: Linux kernel 6.9.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/8b9af6d67517ce4a0015928b3cf35bfd2b1bc1c2
- https://git.kernel.org/stable/c/c86a918b1bdba78fb155184f8d88dfba1e63335d
Get alerted when CVE-2024-42249 or the next vulnerability affects your stack