What’s Vulnerable › Vulnerabilities
CVE-2024-42253: gpio: pca953x: fix pca953x_irq_bus_sync_unlock race
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-08 · updated 2026-08-04
- Weakness: CWE-667
Description
In the Linux kernel, the following vulnerability has been resolved: gpio: pca953x: fix pca953x_irq_bus_sync_unlock race Ensure that `i2c_lock' is held when setting interrupt latch and mask in pca953x_irq_bus_sync_unlock() in order to avoid races. The other (non-probe) call site pca953x_gpio_set_multiple() ensures the lock is held before calling pca953x_write_regs(). The problem occurred when a request raced against irq_bus_sync_unlock() approximately once per thousand reboots on an i.MX8MP based system. * Normal case 0-0022: write register AI|3a {03,02,00,00,01} Input latch P0 0-0022: write register AI|49 {fc,fd,ff,ff,fe} Interrupt mask P0 0-0022: write register AI|08 {ff,00,00,00,00} Output P3 0-0022: write register AI|12 {fc,00,00,00,00} Config P3 * Race case 0-0022: write register AI|08 {ff,00,00,00,00} Output P3 0-0022: write register AI|08 {03,02,00,00,01} *** Wrong register *** 0-0022: write register AI|12 {fc,00,00,00,00} Config P3 0-0022: write register AI|49 {fc,fd,ff,ff,fe} Interrupt mask P0
Affected products
- Linux kernel: before 6.1.101; from 6.2 before 6.6.42; from 6.7 before 6.9.11; 6.10-rc1, 6.10-rc2, 6.10-rc3, 6.10-rc4, 6.10-rc5 — fixed in 6.1.101, 6.6.42, 6.9.11
How to fix
Upgrade to a fixed version: Linux kernel 6.1.101, 6.6.42, 6.9.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/58a5c93bd1a6e949267400080f07e57ffe05ec34
- https://git.kernel.org/stable/c/bfc6444b57dc7186b6acc964705d7516cbaf3904
- https://git.kernel.org/stable/c/de7cffa53149c7b48bd1bb29b02390c9f05b7f41
- https://git.kernel.org/stable/c/e2ecdddca80dd845df42376e4b0197fe97018ba2
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-42253 or the next vulnerability affects your stack