What’s Vulnerable › Vulnerabilities
CVE-2024-42265: protect the fetch of ->fd[fd] in do_dup2() from mispredictions
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-17 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: protect the fetch of ->fd[fd] in do_dup2() from mispredictions both callers have verified that fd is not greater than ->max_fds; however, misprediction might end up with tofree = fdt->fd[fd]; being speculatively executed. That's wrong for the same reasons why it's wrong in close_fd()/file_close_fd_locked(); the same solution applies - array_index_nospec(fd, fdt->max_fds) could differ from fd only in case of speculative execution on mispredicted path.
Affected products
- Linux kernel: before 4.19.320; from 4.20 before 5.4.282; from 5.5 before 5.10.224; from 5.11 before 5.15.165; from 5.16 before 6.1.104; from 6.2 before 6.6.45 — fixed in 4.19.320, 5.10.224, 5.15.165, 5.4.282, 6.1.104, 6.10.4
How to fix
Upgrade to a fixed version: Linux kernel 4.19.320, 5.10.224, 5.15.165, 5.4.282. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/08775b3d6ed117cf4518754ec7300ee42b6a5368
- https://git.kernel.org/stable/c/1171ceccabfd596ca370c5d2cbb47d110c3f2fe1
- https://git.kernel.org/stable/c/3f480493550b6a23d3a65d095d6569d4a7f56a0f
- https://git.kernel.org/stable/c/41a6c31df77bd8e050136b0a200b537da9e1084a
- https://git.kernel.org/stable/c/5db999fff545b924b24c9afd368ef5c17279b176
- https://git.kernel.org/stable/c/8aa37bde1a7b645816cda8b80df4753ecf172bf1
- https://git.kernel.org/stable/c/da72e783afd27d9f487836b2e6738146c0edd149
- https://git.kernel.org/stable/c/ed42e8ff509d2a61c6642d1825032072dab79f26
- https://lists.debian.org/debian-lts-announce/2024/10/msg00003.html
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
- https://cert-portal.siemens.com/productcert/html/ssa-265688.html
Get alerted when CVE-2024-42265 or the next vulnerability affects your stack