What’s Vulnerable › Vulnerabilities
CVE-2024-42288: scsi: qla2xxx: Fix for possible memory corruption
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-17 · updated 2026-08-04
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: qla2xxx: Fix for possible memory corruption Init Control Block is dereferenced incorrectly. Correctly dereference ICB
Affected products
- Linux kernel: before 5.4.282; from 5.5 before 5.10.224; from 5.11 before 5.15.165; from 5.16 before 6.1.103; from 6.2 before 6.6.44; from 6.7 before 6.10.3 — fixed in 5.10.224, 5.15.165, 5.4.282, 6.1.103, 6.10.3, 6.6.44
How to fix
Upgrade to a fixed version: Linux kernel 5.10.224, 5.15.165, 5.4.282, 6.1.103. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2a15b59a2c5afac89696e44acf5bbfc0599c6c5e
- https://git.kernel.org/stable/c/571d7f2a08836698c2fb0d792236424575b9829b
- https://git.kernel.org/stable/c/8192c533e89d9fb69b2490398939236b78cda79b
- https://git.kernel.org/stable/c/87db8d7b7520e99de71791260989f06f9c94953d
- https://git.kernel.org/stable/c/b0302ffc74123b6a99d7d1896fcd9b2e4072d9ce
- https://git.kernel.org/stable/c/c03d740152f78e86945a75b2ad541bf972fab92a
- https://git.kernel.org/stable/c/dae67169cb35a37ecccf60cfcd6bf93a1f4f5efb
- https://lists.debian.org/debian-lts-announce/2024/10/msg00003.html
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-42288 or the next vulnerability affects your stack