What’s Vulnerable › Vulnerabilities
CVE-2024-42322: ipvs: properly dereference pe in ip_vs_add_service
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-17 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: ipvs: properly dereference pe in ip_vs_add_service Use pe directly to resolve sparse warning: net/netfilter/ipvs/ip_vs_ctl.c:1471:27: warning: dereference of noderef expression
Affected products
- Linux kernel: from 4.7 before 5.10.237; from 5.11 before 5.15.181; from 5.16 before 6.1.119; from 6.2 before 6.6.44; from 6.7 before 6.10.3 — fixed in 5.10.237, 5.15.181, 6.1.119, 6.10.3, 6.6.44
How to fix
Upgrade to a fixed version: Linux kernel 5.10.237, 5.15.181, 6.1.119, 6.10.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/211168339657f36f32fb597afd0e3ac82d726119
- https://git.kernel.org/stable/c/36c997f1e03601475ad0fda0e0f59b7a209e756b
- https://git.kernel.org/stable/c/3dd428039e06e1967ce294e2cd6342825aaaad77
- https://git.kernel.org/stable/c/b2c664df3bb46aabac6a5fd78aaa5bd614cfad97
- https://git.kernel.org/stable/c/c420cd5d5bc6797f3a8824e7d74f38f0c286fca5
- https://git.kernel.org/stable/c/cbd070a4ae62f119058973f6d2c984e325bce6e7
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
Get alerted when CVE-2024-42322 or the next vulnerability affects your stack