What’s Vulnerable › Vulnerabilities
CVE-2024-42327: SQL injection in user.get API
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 79.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-27 · updated 2026-06-17
- Weakness: CWE-89
Description
A non-admin user account on the Zabbix frontend with the default User role, or with any other role that gives API access can exploit this vulnerability. An SQLi exists in the CUser class in the addRelatedObjects function, this function is being called from the CUser.get function which is available for every user who has API access.
Affected products
- Zabbix: from 6.0.0 before 6.0.32; from 6.4.0 before 6.4.17; from 7.0.0 before 7.0.1 — fixed in 6.0.32, 6.4.17, 7.0.1
How to fix
Upgrade to a fixed version: Zabbix 6.0.32, 6.4.17, 7.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-42327 or the next vulnerability affects your stack