What’s Vulnerable › Vulnerabilities
CVE-2024-42346: Stored Cross Site Scripting (Stored XSS) in Galaxy
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Galaxy is a free, open-source system for analyzing data, authoring workflows, training and education, publishing tools, managing infrastructure, and more. The editor visualization, /visualizations endpoint, can be used to store HTML tags and trigger javascript execution upon edit operation. All supported branches of Galaxy (and more back to release_20.05) were amended with the supplied patches. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- galaxyproject galaxy: before 24.1.1 — fixed in 24.1.1
How to fix
Upgrade to a fixed version: galaxyproject galaxy 24.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-42346 or the next vulnerability affects your stack