What’s Vulnerable › Vulnerabilities
CVE-2024-42354: Shopware vulnerable to Improper Access Control with ManyToMany associations in store-api
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-08 · updated 2026-06-17
- Weakness: CWE-284
Description
Shopware is an open commerce platform. The store-API works with regular entities and not expose all fields for the public API; fields need to be marked as ApiAware in the EntityDefinition. So only ApiAware fields of the EntityDefinition will be encoded to the final JSON. Prior to versions 6.6.5.1 and 6.5.8.13, the processing of the Criteria did not considered ManyToMany associations and so they were not considered properly and the protections didn't get used. This issue cannot be reproduced with the default entities by Shopware, but can be triggered with extensions. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.2, 6.3, and 6.4, corresponding security measures are also available via a plugin.
Affected products
- shopware: before 6.5.8.13; from 6.6.0.0 before 6.6.5.1 — fixed in 6.5.8.13, 6.6.5.1
How to fix
Upgrade to a fixed version: shopware 6.5.8.13, 6.6.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/shopware/core/commit/a784aa1cec0624e36e0ee4d41aeebaed40e0442f
- https://github.com/shopware/core/commit/d35ee2eda5c995faeb08b3dad127eab65c64e2a2
- https://github.com/shopware/shopware/commit/8504ba7e56e53add6a1d5b9d45015e3d899cd0ac
- https://github.com/shopware/shopware/commit/ad83d38809df457efef21c37ce0996430334bf01
- https://github.com/shopware/shopware/security/advisories/GHSA-hhcq-ph6w-494g
Get alerted when CVE-2024-42354 or the next vulnerability affects your stack