What’s Vulnerable › Vulnerabilities
CVE-2024-42355: Shopware vulnerable to Server Side Template Injection in Twig using deprecation silence tag
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-08 · updated 2026-06-17
- Weakness: CWE-1336
Description
Shopware, an open ecommerce platform, has a new Twig Tag `sw_silent_feature_call` which silences deprecation messages while triggered in this tag. Prior to versions 6.6.5.1 and 6.5.8.13, it accepts as parameter a string the feature flag name to silence, but this parameter is not escaped properly and allows execution of code. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.2, 6.3, and 6.4, corresponding security measures are also available via a plugin.
Affected products
- shopware: before 6.5.8.13; from 6.6.0.0 before 6.6.5.1 — fixed in 6.5.8.13, 6.6.5.1
How to fix
Upgrade to a fixed version: shopware 6.5.8.13, 6.6.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/shopware/core/commit/a784aa1cec0624e36e0ee4d41aeebaed40e0442f
- https://github.com/shopware/core/commit/d35ee2eda5c995faeb08b3dad127eab65c64e2a2
- https://github.com/shopware/shopware/commit/445c6763cc093fbd651e0efaa4150deae4ae60da
- https://github.com/shopware/shopware/commit/8504ba7e56e53add6a1d5b9d45015e3d899cd0ac
- https://github.com/shopware/shopware/security/advisories/GHSA-27wp-jvhw-v4xp
Get alerted when CVE-2024-42355 or the next vulnerability affects your stack