What’s Vulnerable › Vulnerabilities
CVE-2024-42356: Shopware vulnerable to Server Side Template Injection in Twig using Context functions
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-08 · updated 2026-06-17
- Weakness: CWE-1336
Description
Shopware is an open commerce platform. Prior to versions 6.6.5.1 and 6.5.8.13, the `context` variable is injected into almost any Twig Template and allows to access to current language, currency information. The context object allows also to switch for a short time the scope of the Context as a helper with a callable function. The function can be called also from Twig and as the second parameter allows any callable, it's possible to call from Twig any statically callable PHP function/method. It's not possible as customer to provide any Twig code, the attacker would require access to Administration to exploit it using Mail templates or using App Scripts. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.1, 6.2, 6.3 and 6.4 corresponding security measures are also available via a plugin.
Affected products
- shopware: before 6.5.8.13; from 6.6.0.0 before 6.6.5.1 — fixed in 6.5.8.13, 6.6.5.1
How to fix
Upgrade to a fixed version: shopware 6.5.8.13, 6.6.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/shopware/core/commit/04183e0c02af3b404eb7d52c683734bfe0595038
- https://github.com/shopware/core/commit/a784aa1cec0624e36e0ee4d41aeebaed40e0442f
- https://github.com/shopware/shopware/commit/8504ba7e56e53add6a1d5b9d45015e3d899cd0ac
- https://github.com/shopware/shopware/commit/e43423bcc93c618c3036f94c12aa29514da8cf2e
- https://github.com/shopware/shopware/security/advisories/GHSA-35jp-8cgg-p4wj
Get alerted when CVE-2024-42356 or the next vulnerability affects your stack