What’s Vulnerable › Vulnerabilities
CVE-2024-42357: Shopware vulnerable to blind SQL-injection in DAL aggregations
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-08 · updated 2026-06-17
- Weakness: CWE-89
Description
Shopware is an open commerce platform. Prior to versions 6.6.5.1 and 6.5.8.13, the Shopware application API contains a search functionality which enables users to search through information stored within their Shopware instance. The searches performed by this function can be aggregated using the parameters in the `aggregations` object. The `name` field in this `aggregations` object is vulnerable SQL-injection and can be exploited using SQL parameters. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.1, 6.2, 6.3, and 6.4, corresponding security measures are also available via a plugin.
Affected products
- shopware: before 6.5.8.13; from 6.6.0.0 before 6.6.5.1 — fixed in 6.5.8.13, 6.6.5.1
How to fix
Upgrade to a fixed version: shopware 6.5.8.13, 6.6.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/shopware/core/commit/63c05615694790f5790a04ef889f42b764fa53c9
- https://github.com/shopware/core/commit/a784aa1cec0624e36e0ee4d41aeebaed40e0442f
- https://github.com/shopware/shopware/commit/57ea2f3c59483cf7c0f853e7a0d68c23ded1fe5b
- https://github.com/shopware/shopware/commit/8504ba7e56e53add6a1d5b9d45015e3d899cd0ac
- https://github.com/shopware/shopware/security/advisories/GHSA-p6w9-r443-r752
Get alerted when CVE-2024-42357 or the next vulnerability affects your stack