What’s Vulnerable › Vulnerabilities
CVE-2024-42360: Command Injection in sequenceserver
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-14 · updated 2026-10-29
- Weakness: CWE-77
Description
SequenceServer lets you rapidly set up a BLAST+ server with an intuitive user interface for personal or group use. Several HTTP endpoints did not properly sanitize user input and/or query parameters. This could be exploited to inject and run unwanted shell commands. This vulnerability has been fixed in 3.1.2.
Affected products
- wurmlab sequenceserver: before 3.1.2 — fixed in 3.1.2
- wurmlab sequenceserver: before 3.1.2
How to fix
Upgrade to a fixed version: wurmlab sequenceserver 3.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/wurmlab/sequenceserver/commit/457e52709f7f9ed2fceed59b3db564cb50785dba
- https://github.com/wurmlab/sequenceserver/security/advisories/GHSA-qv32-5wm2-p32h
Get alerted when CVE-2024-42360 or the next vulnerability affects your stack