What’s Vulnerable › Vulnerabilities

CVE-2024-42365: Asterisk allows `Write=originate` as sufficient permissions for code execution / `System()` dialplan

Description

Asterisk is an open source private branch exchange (PBX) and telephony toolkit. Prior to asterisk versions 18.24.2, 20.9.2, and 21.4.2 and certified-asterisk versions 18.9-cert11 and 20.7-cert2, an AMI user with `write=originate` may change all configuration files in the `/etc/asterisk/` directory. This occurs because they are able to curl remote files and write them to disk, but are also able to append to existing files using the `FILE` function inside the `SET` application. This issue may result in privilege escalation, remote code execution and/or blind server-side request forgery with arbitrary protocol. Asterisk versions 18.24.2, 20.9.2, and 21.4.2 and certified-asterisk versions 18.9-cert11 and 20.7-cert2 contain a fix for this issue.

Affected products

How to fix

Upgrade to a fixed version: Asterisk 18.24.2, 20.9.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-42365 or the next vulnerability affects your stack