What’s Vulnerable › Vulnerabilities
CVE-2024-42366: VR Overlay RCE
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-08 · updated 2026-06-17
- Weakness: CWE-79
Description
VRCX is an assistant/companion application for VRChat. In versions prior to 2024.03.23, a CefSharp browser with over-permission and cross-site scripting via overlay notification can be combined to result in remote command execution. These vulnerabilities are patched in VRCX 2023.12.24. In addition to the patch, VRCX maintainers worked with the VRC team and blocked the older version of VRCX on the VRC's API side. Users who use the older version of VRCX must update their installation to continue using VRCX.
Affected products
- vrcx-team VRCX: before 2024.03.23 — fixed in 2024.03.23
How to fix
Upgrade to a fixed version: vrcx-team VRCX 2024.03.23. Check the vendor advisory for mitigations.
References
- https://github.com/vrcx-team/VRCX/commit/cd2387aa3289f936ce60049121c24b0765bd4180
- https://github.com/vrcx-team/VRCX/security/advisories/GHSA-j98g-mgjm-wqph
Get alerted when CVE-2024-42366 or the next vulnerability affects your stack