What’s Vulnerable › Vulnerabilities
CVE-2024-42381
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-31 · updated 2026-06-17
- Weakness: CWE-830
Description
os/linux/elf.rb in Homebrew brew before 4.2.20 uses ldd to load ELF files obtained from untrusted sources, which allows attackers to achieve code execution via an ELF file with a custom .interp section. NOTE: this code execution would occur during an un-sandboxed binary relocation phase, which occurs before a user would expect execution of downloaded package content. (237d1e783f7ee261beaba7d3f6bde22da7148b0a was the tested vulnerable version.)
Affected products
- Homebrew Brew: before 4.2.20 — fixed in 4.2.20
How to fix
Upgrade to a fixed version: Homebrew Brew 4.2.20. Check the vendor advisory for mitigations.
References
- https://blog.trailofbits.com/2024/07/30/our-audit-of-homebrew/
- https://brew.sh/2024/07/30/homebrew-security-audit/
- https://github.com/Homebrew/brew/commit/916b37388d3851a8a93a8e9b4adc38873680ead7
- https://github.com/Homebrew/brew/pull/17136
- https://github.com/Homebrew/brew/releases/tag/4.2.20
- https://github.com/Homebrew/brew/tree/237d1e783f7ee261beaba7d3f6bde22da7148b0a
- https://github.com/trailofbits/publications/blob/master/reviews/2023-08-28-homebrew-securityreview.pdf
Get alerted when CVE-2024-42381 or the next vulnerability affects your stack