What’s Vulnerable › Vulnerabilities
CVE-2024-42404
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-18 · updated 2026-06-17
- Weakness: CWE-89
Description
SQL injection vulnerability in Welcart e-Commerce prior to 2.11.2 allows an attacker who can login to the product to obtain or alter the information stored in the database.
Affected products
- Welcart e-Commerce: before 2.11.2 — fixed in 2.11.2
How to fix
Upgrade to a fixed version: Welcart e-Commerce 2.11.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-42404 or the next vulnerability affects your stack