What’s Vulnerable › Vulnerabilities
CVE-2024-42407
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-532
Description
Insertion of Sensitive Information into Log File (CWE-532) in the Gallagher Command Centre Alarm Transmitter feature could allow an authenticated Operator to view some security sensitive information to which they have not been granted access. This issue affects: Command Centre Server 9.10 prior to 9.10.2149 (MR4), 9.00 prior to 9.00.2374 (MR5), 8.90 prior to 8.90.2356 (MR6), all versions of 8.80 and prior.
Affected products
- Gallagher Command Centre: through 8.80; from 9.10 before 9.10.2149 (MR4); from 9.00 before 9.00.2374 (MR5); from 8.90 before 8.90.2356 (MR6) — fixed in 8.90.2356 (MR6), 9.00.2374 (MR5), 9.10.2149 (MR4)
How to fix
Upgrade to a fixed version: Gallagher Command Centre 8.90.2356 (MR6), 9.00.2374 (MR5), 9.10.2149 (MR4). Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-42407 or the next vulnerability affects your stack