What’s Vulnerable › Vulnerabilities
CVE-2024-42456
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-04 · updated 2026-06-17
- Weakness: CWE-306
Description
A vulnerability in Veeam Backup & Replication platform allows a low-privileged user with a specific role to exploit a method that updates critical configuration settings, such as modifying the trusted client certificate used for authentication on a specific port. This can result in unauthorized access, enabling the user to call privileged methods and initiate critical services. The issue arises due to insufficient permission requirements on the method, allowing users with low privileges to perform actions that should require higher-level permissions.
Affected products
- Veeam Backup & Replication: from 12.0.0.1402 before 12.3.0.310 — fixed in 12.3.0.310
How to fix
Upgrade to a fixed version: Veeam Backup & Replication 12.3.0.310. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-42456 or the next vulnerability affects your stack