What’s Vulnerable › Vulnerabilities
CVE-2024-42458
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-02 · updated 2026-06-17
- Weakness: CWE-20
Description
server.c in Neat VNC (aka neatvnc) before 0.8.1 does not properly validate the security type, a related issue to CVE-2006-2369.
Affected products
- any1 neatvnc: before 0.8.1 — fixed in 0.8.1
How to fix
Upgrade to a fixed version: any1 neatvnc 0.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/any1/neatvnc/commit/cc71650a69abc2573a0d96d082409d2468802d47
- https://github.com/any1/neatvnc/compare/v0.8.0...v0.8.1
- https://github.com/any1/neatvnc/releases/tag/v0.8.1
- https://www.openwall.com/lists/oss-security/2024/08/02/1
- https://www.openwall.com/lists/oss-security/2024/08/02/10
- https://www.openwall.com/lists/oss-security/2024/08/02/7
Get alerted when CVE-2024-42458 or the next vulnerability affects your stack