What’s Vulnerable › Vulnerabilities
CVE-2024-42469: CometVisu Backend for openHAB affected by RCE through path traversal
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-12 · updated 2026-06-17
- Weakness: CWE-22
Description
openHAB, a provider of open-source home automation software, has add-ons including the visualization add-on CometVisu. Prior to version 4.2.1, CometVisu's file system endpoints don't require authentication and additionally the endpoint to update an existing file is susceptible to path traversal. This makes it possible for an attacker to overwrite existing files on the openHAB instance. If the overwritten file is a shell script that is executed at a later time, this vulnerability can allow remote code execution by an attacker. Users should upgrade to version 4.2.1 to receive a patch.
Affected products
- openhab-webui: before 4.2.1 — fixed in 4.2.1
How to fix
Upgrade to a fixed version: openhab-webui 4.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/openhab/openhab-webui/commit/630e8525835c698cf58856aa43782d92b18087f2
- https://github.com/openhab/openhab-webui/security/advisories/GHSA-f729-58x4-gqgf
Get alerted when CVE-2024-42469 or the next vulnerability affects your stack