What’s Vulnerable › Vulnerabilities
CVE-2024-42470: CometVisu Backend for openHAB has a sensitive information disclosure vulnerability
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-12 · updated 2026-06-17
- Weakness: CWE-862
Description
openHAB, a provider of open-source home automation software, has add-ons including the visualization add-on CometVisu. Several endpoints in versions prior to 4.2.1 of the CometVisu add-on of openHAB don't require authentication. This makes it possible for unauthenticated attackers to modify or to steal sensitive data. This issue may lead to sensitive information disclosure. Users should upgrade to version 4.2.1 of the CometVisu add-on of openHAB to receive a patch.
Affected products
- openhab-webui: before 4.2.1 — fixed in 4.2.1
How to fix
Upgrade to a fixed version: openhab-webui 4.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/openhab/openhab-webui/commit/630e8525835c698cf58856aa43782d92b18087f2
- https://github.com/openhab/openhab-webui/security/advisories/GHSA-3g4c-hjhr-73rj
Get alerted when CVE-2024-42470 or the next vulnerability affects your stack