What’s Vulnerable › Vulnerabilities
CVE-2024-42490: authentik has Insufficient Authorization for several API endpoints
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-22 · updated 2026-06-17
- Weakness: CWE-285
Description
authentik is an open-source Identity Provider. Several API endpoints can be accessed by users without correct authentication/authorization. The main API endpoints affected by this are /api/v3/crypto/certificatekeypairs/<uuid>/view_certificate/, /api/v3/crypto/certificatekeypairs/<uuid>/view_private_key/, and /api/v3/.../used_by/. Note that all of the affected API endpoints require the knowledge of the ID of an object, which especially for certificates is not accessible to an unprivileged user. Additionally the IDs for most objects are UUIDv4, meaning they are not easily guessable/enumerable. authentik 2024.4.4, 2024.6.4 and 2024.8.0 fix this issue.
Affected products
- goauthentik authentik: before 2024.4.4; from 2024.6.0 before 2024.6.4 — fixed in 2024.4.4, 2024.6.4
How to fix
Upgrade to a fixed version: goauthentik authentik 2024.4.4, 2024.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/goauthentik/authentik/commit/19318d4c00bb02c4ec3c4f8f15ac2e1dbe8d846c
- https://github.com/goauthentik/authentik/commit/359b343f51524342a5ca03828e7c975a1d654b11
- https://github.com/goauthentik/authentik/security/advisories/GHSA-qxqc-27pr-wgc8
Get alerted when CVE-2024-42490 or the next vulnerability affects your stack