What’s Vulnerable › Vulnerabilities

CVE-2024-42497: Insufficient permissions checks on teams

Description

Mattermost versions 9.9.x <= 9.9.1, 9.5.x <= 9.5.7, 9.10.x <= 9.10.0, 9.8.x <= 9.8.2 fail to properly enforce permissions which allows a user with systems manager role with read-only access to teams to perform write operations on teams.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 9.5.8, 9.8.3, 9.9.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-42497 or the next vulnerability affects your stack