What’s Vulnerable › Vulnerabilities
CVE-2024-42503: Authenticated Remote Command Execution (RCE) Vulnerability in the Lua Package Within the AOS Command Line Interface (CLI)
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-17 · updated 2026-06-17
- Weakness: CWE-78
Description
Authenticated command execution vulnerability exist in the ArubaOS command line interface (CLI). Successful exploitation of this vulnerabilities result in the ability to run arbitrary commands as a priviledge user on the underlying operating system.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 10.3.0.0 before 10.4.0.0; from 10.5.0.0 before 10.6.0.0; from 10.6.0.0 through 10.6.0.2; from 6.5.4.0 before 6.5.5.0; from 8.6.0.0 through 8.10.0.13 — fixed in 10.4.0.0, 10.6.0.0, 6.5.5.0
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 10.4.0.0, 10.6.0.0, 6.5.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-42503 or the next vulnerability affects your stack