What’s Vulnerable › Vulnerabilities
CVE-2024-4260: CoBlocks < 3.1.12 - Contributor+ SSRF
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-23 · updated 2026-06-17
- Weakness: CWE-918
Description
The Page Builder Gutenberg Blocks WordPress plugin before 3.1.12 does not prevent users from pinging arbitrary hosts via some of its shortcodes, which could allow high privilege users such as contributors to perform SSRF attacks.
Affected products
- godaddy Page Builder Gutenberg Blocks – CoBlocks: before 3.1.12 — fixed in 3.1.12
How to fix
Upgrade to a fixed version: godaddy Page Builder Gutenberg Blocks – CoBlocks 3.1.12. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/69f33e20-8ff4-491c-8f37-a4eadd4ea8cf/
- https://wpscan.com/vulnerability/69f33e20-8ff4-491c-8f37-a4eadd4ea8cf/
Get alerted when CVE-2024-4260 or the next vulnerability affects your stack