What’s Vulnerable › Vulnerabilities
CVE-2024-4266: MetForm – Contact Form, Survey, Quiz, & Custom Form Builder for Elementor <= 3.8.8 - Unauthenticated Sensitive Information Exposure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-11 · updated 2026-06-17
- Weakness: CWE-200
Description
The MetForm – Contact Form, Survey, Quiz, & Custom Form Builder for Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 3.8.8 via the 'handle_file' function. This can allow unauthenticated attackers to extract sensitive data, such as Personally Identifiable Information, from files uploaded by users.
Affected products
- roxnor MetForm – Contact Form, Survey, Quiz, & Custom Form Builder for Elementor: before 3.8.9 — fixed in 3.8.9
How to fix
Upgrade to a fixed version: roxnor MetForm – Contact Form, Survey, Quiz, & Custom Form Builder for Elementor 3.8.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/metform/trunk/core/entries/action.php#L1019
- https://plugins.trac.wordpress.org/changeset/3099977/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8edb72f5-dda3-4c59-ba7a-7a460cb59c03?source=cve
- https://plugins.trac.wordpress.org/browser/metform/trunk/core/entries/action.php#L1019
- https://plugins.trac.wordpress.org/changeset/3099977/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8edb72f5-dda3-4c59-ba7a-7a460cb59c03?source=cve
Get alerted when CVE-2024-4266 or the next vulnerability affects your stack