What’s Vulnerable › Vulnerabilities
CVE-2024-4268: Ultimate Blocks – WordPress Blocks Plugin <= 3.1.9 - Authenticated(Contributor+) Stored Cross-Site Scripting via Multiple Blocks
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ultimate Blocks – WordPress Blocks Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's blocks in all versions up to, and including, 3.1.9 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. CVE-2024-37457 may be a duplicate of this issue.
Affected products
- ultimateblocks Ultimate Blocks – 25+ Gutenberg Blocks for Block Editor: before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: ultimateblocks Ultimate Blocks – 25+ Gutenberg Blocks for Block Editor 3.2.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ultimate-blocks/trunk/src/blocks/advanced-heading/block.php
- https://plugins.trac.wordpress.org/browser/ultimate-blocks/trunk/src/blocks/how-to/block.php
- https://plugins.trac.wordpress.org/browser/ultimate-blocks/trunk/src/blocks/image-slider/block.php
- https://plugins.trac.wordpress.org/browser/ultimate-blocks/trunk/src/blocks/styled-box/block.php
- https://plugins.trac.wordpress.org/browser/ultimate-blocks/trunk/src/blocks/testimonial/block.php
- https://plugins.trac.wordpress.org/browser/ultimate-blocks/trunk/src/extensions/custom-css/class-custom-css.php?rev=3102541#L173
- https://plugins.trac.wordpress.org/changeset/3075315/ultimate-blocks
- https://plugins.trac.wordpress.org/changeset/3108401/
- https://wordpress.org/plugins/ultimate-blocks/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/00b60b53-77bf-4640-bf2b-84e011014623?source=cve
- https://gist.github.com/webber-naut/0a8a4f810da286392a43c4614d31712e
- https://plugins.trac.wordpress.org/browser/ultimate-blocks/trunk/src/blocks/advanced-heading/block.php
Get alerted when CVE-2024-4268 or the next vulnerability affects your stack