What’s Vulnerable › Vulnerabilities
CVE-2024-4269: SVG Block < 1.1.20 - Author+ Stored XSS via SVG File Upload
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The SVG Block WordPress plugin before 1.1.20 does not sanitize SVG file contents, which enables users with at least the author role to SVG with malicious JavaScript to conduct Stored XSS attacks.
Affected products
- SVG Block: before 1.1.20 — fixed in 1.1.20
How to fix
Upgrade to a fixed version: SVG Block 1.1.20. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8aae7aa1-6170-45d8-903f-8520913276da/
- https://wpscan.com/vulnerability/8aae7aa1-6170-45d8-903f-8520913276da/
Get alerted when CVE-2024-4269 or the next vulnerability affects your stack