What’s Vulnerable › Vulnerabilities
CVE-2024-42698
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-28 · updated 2026-06-17
- Weakness: CWE-129
Description
Roughly Enough Items (REI) v.16.0.729 and before contains an Improper Validation of Specified Index, Position, or Offset in Input vulnerability. The specific issue is a failure to validate slot index and decrement stack count in the Roughly Enough Items (REI) mod for Minecraft, which allows in-game item duplication.
Affected products
- Shedaniel Roughlyenoughitems: before 16.0.744 — fixed in 16.0.744
How to fix
Upgrade to a fixed version: Shedaniel Roughlyenoughitems 16.0.744. Check the vendor advisory for mitigations.
References
- https://gist.github.com/apple502j/7b1af0082449c9bfbf910e9a25ef3595
- https://github.com/shedaniel/RoughlyEnoughItems/commit/e80ca84f1affb91d2388ddb298bfc6b141828cad
Get alerted when CVE-2024-42698 or the next vulnerability affects your stack