What’s Vulnerable › Vulnerabilities
CVE-2024-4272: Support SVG < 1.1.0 - Stored XSS via SVG Upload
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Support SVG WordPress plugin before 1.1.0 does not sanitize SVG file contents, which enables users with at least the author role to SVG with malicious JavaScript to conduct Stored XSS attacks.
Affected products
- Support SVG: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: Support SVG 1.1.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ed1b1540-a0e2-434e-8769-9532c3ed5e31/
- https://wpscan.com/vulnerability/ed1b1540-a0e2-434e-8769-9532c3ed5e31/
Get alerted when CVE-2024-4272 or the next vulnerability affects your stack