What’s Vulnerable › Vulnerabilities
CVE-2024-4273: Essential Real Estate <= 4.4.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Essential Real Estate plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'ere_property_map' shortcode in all versions up to, and including, 4.4.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- g5theme Essential Real Estate: before 4.4.3 — fixed in 4.4.3
How to fix
Upgrade to a fixed version: g5theme Essential Real Estate 4.4.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3097110%40essential-real-estate&new=3097110%40essential-real-estate&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/essential-real-estate/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c62ec31a-55e9-4404-b860-fa9a51ba3d3f?source=cve
- https://wordpress.org/plugins/essential-real-estate/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c62ec31a-55e9-4404-b860-fa9a51ba3d3f?source=cve
Get alerted when CVE-2024-4273 or the next vulnerability affects your stack