What’s Vulnerable › Vulnerabilities
CVE-2024-4278: Incorrect Synchronization in GitLab
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-26 · updated 2026-06-17
- Weakness: CWE-821
Description
An information disclosure issue has been discovered in GitLab EE affecting all versions starting from 16.5 prior to 17.2.8, from 17.3 prior to 17.3.4, and from 17.4 prior to 17.4.1. A maintainer could obtain a Dependency Proxy password by editing a certain Dependency Proxy setting.
Affected products
- GitLab: from 16.5.0 before 17.2.8; from 17.3.0 before 17.3.4; 17.4.0 — fixed in 17.2.8, 17.3.4
How to fix
Upgrade to a fixed version: GitLab 17.2.8, 17.3.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-4278 or the next vulnerability affects your stack