What’s Vulnerable › Vulnerabilities
CVE-2024-4279: Tutor LMS – eLearning and online course solution <= 2.7.0 - Authenticated (Instructor+) Insecure Direct Object Reference to Arbitrary Course Deletion
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-639
Description
The Tutor LMS – eLearning and online course solution plugin for WordPress is vulnerable to Insecure Direct Object Reference to Arbitrary Course Deletion in versions up to, and including, 2.7.0 via the 'tutor_course_delete' function due to missing validation on a user controlled key. This can allow authenticated attackers, with Instructor-level permissions and above, to delete any course.
Affected products
- themeum Tutor LMS – eLearning and online course solution: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 2.7.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/tutor/trunk/classes/Course_List.php#L357
- https://plugins.trac.wordpress.org/changeset/3086489/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/45d04643-e43a-4732-91bf-e4af7b622e33?source=cve
- https://plugins.trac.wordpress.org/browser/tutor/trunk/classes/Course_List.php#L357
- https://plugins.trac.wordpress.org/changeset/3086489/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/45d04643-e43a-4732-91bf-e4af7b622e33?source=cve
Get alerted when CVE-2024-4279 or the next vulnerability affects your stack