What’s Vulnerable › Vulnerabilities
CVE-2024-4284: Denial of Service in mintplex-labs/anything-llm
- Severity: medium (CVSS 4.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-19 · updated 2026-06-17
- Weakness: CWE-400
Description
A vulnerability in mintplex-labs/anything-llm allows for a denial of service (DoS) condition through the modification of a user's `id` attribute to a value of 0. This issue affects the current version of the software, with the latest commit id `57984fa85c31988b2eff429adfc654c46e0c342a`. By exploiting this vulnerability, an attacker, with manager or admin privileges, can render a chosen account completely inaccessible. The application's mechanism for suspending accounts does not provide a means to reverse this condition through the UI, leading to uncontrolled resource consumption. The vulnerability is introduced due to the lack of input validation and sanitization in the user modification endpoint and the middleware's token validation logic. This issue has been addressed in version 1.0.0 of the software.
Affected products
- Mintplexlabs Anythingllm: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: Mintplexlabs Anythingllm 1.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/mintplex-labs/anything-llm/commit/1b35bcbeab10b77e6dbd263cceecf1b965a40789
- https://huntr.com/bounties/a5f45596-0aef-49e0-9f7d-63f1955a1552
- https://github.com/mintplex-labs/anything-llm/commit/1b35bcbeab10b77e6dbd263cceecf1b965a40789
- https://huntr.com/bounties/a5f45596-0aef-49e0-9f7d-63f1955a1552
Get alerted when CVE-2024-4284 or the next vulnerability affects your stack