What’s Vulnerable › Vulnerabilities
CVE-2024-4287: Improper Input Validation in mintplex-labs/anything-llm
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-20 · updated 2026-06-17
- Weakness: CWE-20
Description
In mintplex-labs/anything-llm, a vulnerability exists due to improper input validation in the workspace update process. Specifically, the application fails to validate or format JSON data sent in an HTTP POST request to `/api/workspace/:workspace-slug/update`, allowing it to be executed as part of a database query without restrictions. This flaw enables users with a manager role to craft a request that includes nested write operations, effectively allowing them to create new Administrator accounts.
Affected products
- Mintplexlabs Anythingllm: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: Mintplexlabs Anythingllm 1.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/mintplex-labs/anything-llm/commit/94b58249a37a21b1c08deaa2d1edfdecbb6deb18
- https://huntr.com/bounties/34491fb7-5133-4e80-8782-74124350bbdb
- https://github.com/mintplex-labs/anything-llm/commit/94b58249a37a21b1c08deaa2d1edfdecbb6deb18
- https://huntr.com/bounties/34491fb7-5133-4e80-8782-74124350bbdb
Get alerted when CVE-2024-4287 or the next vulnerability affects your stack