What’s Vulnerable › Vulnerabilities
CVE-2024-4288: Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin <= 1.6.7.14 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘link’ parameter in versions up to, and including, 1.6.7.14 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- croixhaug Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin: before 1.6.7.18 — fixed in 1.6.7.18
How to fix
Upgrade to a fixed version: croixhaug Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin 1.6.7.18. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/simply-schedule-appointments/trunk/includes/class-shortcodes.php#L677
- https://plugins.trac.wordpress.org/changeset/3087297/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/84262b4a-a662-4aaf-9eae-f5cca8f6cd06?source=cve
- https://plugins.trac.wordpress.org/browser/simply-schedule-appointments/trunk/includes/class-shortcodes.php#L677
- https://plugins.trac.wordpress.org/changeset/3087297/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/84262b4a-a662-4aaf-9eae-f5cca8f6cd06?source=cve
Get alerted when CVE-2024-4288 or the next vulnerability affects your stack