What’s Vulnerable › Vulnerabilities
CVE-2024-42906
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-26 · updated 2026-06-17
- Weakness: CWE-79
Description
TestLink before v.1.9.20 is vulnerable to Cross Site Scripting (XSS) via the pop-up on upload file. When uploading a file, the XSS payload can be entered into the file name.
Affected products
- Testlink: before 1.9.20 — fixed in 1.9.20
How to fix
Upgrade to a fixed version: Testlink 1.9.20. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-42906 or the next vulnerability affects your stack