What’s Vulnerable › Vulnerabilities
CVE-2024-43027
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-21 · updated 2026-06-17
- Weakness: CWE-77
Description
DrayTek Vigor 3900 before v1.5.1.5_Beta, DrayTek Vigor 2960 before v1.5.1.5_Beta and DrayTek Vigor 300B before v1.5.1.5_Beta were discovered to contain a command injection vulnerability via the action parameter at cgi-bin/mainfunction.cgi.
Affected products
- DrayTek Vigor2960: before 1.5.1.5 — fixed in 1.5.1.5
- DrayTek Vigor 300B: before 1.5.1.5 — fixed in 1.5.1.5
- DrayTek Vigor3900 Firmware: before 1.5.1.5 — fixed in 1.5.1.5
How to fix
Upgrade to a fixed version: DrayTek Vigor2960 1.5.1.5; DrayTek Vigor 300B 1.5.1.5; DrayTek Vigor3900 Firmware 1.5.1.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-43027 or the next vulnerability affects your stack