What’s Vulnerable › Vulnerabilities
CVE-2024-43035
- Severity: medium (CVSS 5.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-05 · updated 2026-06-17
- Weakness: CWE-24
Description
Fonoster 0.5.5 before 0.6.1 allows ../ directory traversal to read arbitrary files via the /sounds/:file or /tts/:file VoiceServer endpoint. This occurs in serveFiles in mods/voice/src/utils.ts. NOTE: serveFiles exists in 0.5.5 but not in the next release, 0.6.1.
Affected products
- fonoster: from 0.5.5 before 0.6.1 — fixed in 0.6.1
How to fix
Upgrade to a fixed version: fonoster 0.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/fonoster/fonoster/blob/4a1438d9dedeaf7b2a5b6a50d5e233f994e2b2cf/mods/voice/src/utils.ts#L66-L70
- https://zeropath.com/blog/fonoster-voiceserver-lfi-vulnerability
Get alerted when CVE-2024-43035 or the next vulnerability affects your stack