What’s Vulnerable › Vulnerabilities

CVE-2024-43045

Description

Jenkins 2.470 and earlier, LTS 2.452.3 and earlier does not perform a permission check in an HTTP endpoint, allowing attackers with Overall/Read permission to access other users' "My Views".

Affected products

How to fix

Upgrade to a fixed version: Jenkins 2.452.4, 2.471. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-43045 or the next vulnerability affects your stack