What’s Vulnerable › Vulnerabilities
CVE-2024-4305: PostX < 4.1.0 - Contributor+ Stored XSS
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Post Grid Gutenberg Blocks and WordPress Blog Plugin WordPress plugin before 4.1.0 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- WPXPO PostX: before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: WPXPO PostX 4.1.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/635be98d-4c17-4e75-871f-9794d85a2eb1/
- https://wpscan.com/vulnerability/635be98d-4c17-4e75-871f-9794d85a2eb1/
Get alerted when CVE-2024-4305 or the next vulnerability affects your stack